우분투 PHP7 버전 선택해서 설치하는 방법

우분투에서 패키지를 설치할때 사용하는 APT 명령어는 우분투 기본 리포지토리(Repository)에 올라온 패키지만 설치할 수 있는데요.

PHP7 같은 경우 최신 버전만 유지되는데, 사용하는 어플리케이션에 따라서 PHP7.0이나 PHP7.1을 유지해야 하는 경우도 있습니다.

이전에 설치해둔 서버라면 상관 없지만 최근에 웹서버를 세팅하는 경우 기본 리포지토리에서 PHP7.2만 설치할 수 있는데, 이전 버전을 설치하고 싶다면 다음과 같은 방법으로 진행합니다.

PHP7 PPA 추가

sudo add-apt-repository ppa:ondrej/php
sudo apt update

PHP7을 버전별로 배포하는 PPA(Personal Package Archive)를 추가하면 원하는 PHP7의 하위 버전을 선택적으로 설치할 수 있습니다.

위 명령어로 PPA를 추가한 다음 저장소 정보를 업데이트합니다.

Php7 Choosing Install Version 01

sudo apt search php7.0
sudo apt install libapache2-mod-php7.0 php7.0 php7.0-common php7.0-cli libphp7.0-embed php7.0-bcmath php7.0-bz2 php7.0-cgi  php7.0-curl php7.0-dba php7.0-dev php7.0-enchant php7.0-gd php7.0-gmp php7.0-imap php7.0-intl php7.0-json php7.0-ldap php7.0-mbstring php7.0-mcrypt php7.0-mysql php7.0-opcache php7.0-phpdbg php7.0-pspell php7.0-readline php7.0-recode php7.0-snmp php7.0-soap php7.0-tidy php7.0-xml php7.0-xmlrpc php7.0-xsl php7.0-zip

위 명령어로 원하는 버전의 PHP7 패키지를 검색해본 다음 설치할 수 있습니다.

추천 글

댓글

이메일 주소는 공개되지 않으며 댓글에 하나 이상의 URL이 포함될 경우 관리자 승인 후 공개됩니다.

댓글은 운영 정책에 따라 관리됩니다. (링크)